Jump to content
RF-Dev | RF Online Development
Ron

RF Online Server Files - Version 2.2.3.2, Golden Age

Recommended Posts

You must be a registered member of RF-Dev and logged in to view this content.

 

The issue with tcpview showing 204.204.204.204 is common when attempting to allow WAN connections from a server configured on LAN. The loginserver returns this IP when it is unable to connect to the zoneserver IP (WAN IP). This is caused by your local system not being able to connect to your WAN IP (loopback connections not working). 

Please check my post here to see if this applies to you.

 

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

Everything is set to LAN (127.0.0.1) and I'm running it in a VM using VMware Workstation 14 Player with Windows 10 x64. Would running in a VM interfere with things? Thank you for your help.

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

I'm also using VM as my dev server.

I run my client at my host machine and the VM network configuration is set to host only, so the host and the VM can communicate using class c ip address.

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

You'll need to set up a virtual network and make sure each system has its own VMware LAN IP assigned. You wont' be able to connect to 127.0.0.1 from your local PC to a service on the VMware OS. Configuring a network is required to talk from your local OS to the guest OS.

You must be a registered member of RF-Dev and logged in to view this content.

 

I have successfully configured RF in a guest OS on VirtualBox a few times. I've used VMware but never for RF. Either way, you'll need to configure the virtual network then test that each OS can talk to each other with a ping test. Once that's working set all server-side IPs to the IP of the guest OS. Set the guest OS IP in your client and you should then be able to connect.

However, this will only allow connections from systems configured on the virtual network. As far as allowing public network connections to access the server on the guest OS, you'll need to get in to some tricky network routing settings. It is significantly easier to host on a server where the public WAN IP is bound directly to the system (WAN IP showing in `ipconfig`), and not behind a LAN.

The easiest way is to share the connection from the host OS to the guest OS, forward the ports to your host OS LAN IP, then set which guest OS to forward each port to in your virtualization settings. Other players will be able to connect, but the problem is you will not be able to connect from the host OS to the server on the guest OS (explained in my other posts).

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

I am running the client in the same VM as the server so everything should be localhost.

As for the allowing public connecting to a VM, that's pretty easy. VMware has an option to set a bridged network connection so it connects directly to the router. In the router I can see the VM MAC address and I have successfully tested it with a HTTP server. Capture.PNG.86e52e4ddbbdb6cec67d54653b007626.PNG Anyway, that's not the problem here, just trying to run the server locally.

I've reinstalled everything over 5 times now. I can input any combination of user:password in the launcher and it will accept it and the "Processing User Count" in the Login server will update but nothing else happens.asdasdsa.PNG.18ebf7826830acd03eea8a121c396a77.PNG

Could this have anything to do with the NationCode? I haven't really figured out what's its purpose. All of the .ini are using TH NationCode except for BillingSystem which is using US (it will throw an error with TH and RU, only US seems to work).nationcode.PNG.a8a0d88f7925a51ffc5322dda43c1cd9.PNG EDIT I've changed everything to NationCode US and it's the same.

P.S. I love this forum software. Good job.

 

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

Edited by OldSchool

Share this post


Link to post
Share on other sites

Here are all my .ini files. INI.zip contains all of them.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

You must be a registered member of RF-Dev and logged in to view this content.

Edited by OldSchool

Share this post


Link to post
Share on other sites

I've reinstalled everything for the 100th time and things are looking a bit better. Now those windows show some new positive info. Still doesn't work though. This is driving me crazy. I have a feeling it's somehow because of the NationCode, I gotta understand how they work.

You must be a registered member of RF-Dev and logged in to view this content.

Edited by OldSchool

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

 

Sorry about that. I thought you were trying to connect to the server running in a guest.

You shouldn't need to modify the nation codes, just the server IPs. 

I had this same problem last year when I last looked at these files. I don't remember the exact fix but I did work around this. If I need to configure the files again to figure it out I don't mind doing so. I need to revise the files for this post anyway as they have a lot of easy issues that can be fixed out of the box.

Are you on discord? If so, send me a PM there and we can discuss more.

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

I literally just got it to work at the exact same time I got a notification of your comment. Problem is I don't know what I did to fix it... I changed so many things at once because I was frustrated. I'm gonna review everything and save the exact configuration. It's such a wonderful feeling entering the RF world after so many days of looking through hundreds of comments in the worst broken English and SO. MANY. DEAD. LINKS. xD

Thanks!

Next step is to get it to run on WAN.

You must be a registered member of RF-Dev and logged in to view this content.

Edited by OldSchool

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

Congrats. I'm glad to hear it's working now.

Yeah, the process isn't exactly straightforward. I have some ideas to address this but my free time is limited lately. We'll have updates soon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...