Jump to content
RF-Dev | RF Online Development
Ron

RF Online Server Files - Version 2.2.3.2, Golden Age

Recommended Posts

Server files for RF Online 2.2.3.2 Golden Age (GA) / Golden Update (GU). These files should have minimal changes from their original state (clean).

Some issues exist with these files. Feel free to discuss any problems with the files in this thread so everyone can share fixes.

 

Server Files 
You must be a registered member of RF-Dev and logged in to view this content.

 

Game Client

You will need to set up the Launcher Update Emulator to use the official launcher. You can also reference the Developer Launcher to fast track getting in-game, or reference the source code to create your own launcher.

 

Setup Guides

 

Alternate Database Files

Try these databases if you experience issues logging in with the databases included in the server files.

RF Tool Pack

 

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

you can download this  first You must be a registered member of RF-Dev and logged in to view this content. (Full Client Patron) second Download This You must be a registered member of RF-Dev and logged in to view this content. Then Extract to Folder Full Clinet For Reserve Patch to Golden Mystery

Share this post


Link to post
Share on other sites

111.JPG.88c13f5c432a7c9c25375ee18e617728.JPG

After doing the Setup, all Server side files were running but when connecting the client window doesn't open but you can see in the process that RF_Online.bin is running. After minutes this error pops up. Hope someone can help on my problem.

Using this Server Files + PlayRF Client + Dev Launcher + Yorozura Zone Server (Also tried the default ZoneServer but has same issues too)

Share this post


Link to post
Share on other sites

I do not know why, but when I used Dev-Launcher I gave this error message.
RF_Online.bin started and after a few seconds or minutes this message appeared.

Usually to resolve this error in the GateIP and Andress in the Zoneserver .ini.

Edited by LewS

Share this post


Link to post
Share on other sites
You must be a registered member of RF-Dev and logged in to view this content.

Use tcpview and check the IP that RF_Online.exe is trying to connect to. If tcpview shows IP 204.204.204.204, the zoneserver isn't detecting the system IP properly to send to the client.

I had this issue when I set up 2.2.3 last, and it was fixed by adding GateIP to the zoneserver INI.

If running locally, set GateIP to your LAN IP or 127.0.0.1. If running server remotely, set GateIP to your WAN IP (whatismyip.com). 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×